macos mojave
Foto (unbearbeitet): unsplash/ Derek Thomson

macOS Mojave auf nicht unterstützten Geräten installieren – Eine deutsche Anleitung

TheQuickSaveGamer’s Contentcreator unterstützen – jetzt direkt Spenden!

Auf etwas älteren Apple Geräten lässt sich das neuste macOS Mojave nicht mehr per Update installieren. Apple unterdrückt dies akribisch. Doch mit nur wenigen Umständen lässt sich auch auf älteren Geräten Mojave installieren. Aus meiner Erfahrung beim 2009er MacBook Pro 13″ läuft El Capitan vielleicht auch nur minimal runder. Die Installation ist nicht schwierig, sollte aber auf jeden Fall euer aktuellstes offizielle MacOS nicht ersetzen, sondern auf einer neuen Partition installiert werden. Wie das geht erfährst du in diesem Artikel. Alle benutzen Bilder stammen hierbei aus dem originalen Artikel des Patch-Entwicklers, durch den all das erst möglich wird. Ihr könnt ihn dort auch per PayPal unterstützen.

Anleitungen zum Catalina Patcher, zum High Sierra und zum Sierra Patcher findest du hier.

Außerdem ist etwas Erfahrung von Vorteil.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro


Benötigt wird:

  • eines der folgenden Apple-Geräte:
    • – Frühjahr-2008 oder neueren Mac Pro, iMac, oder MacBook Pro:
      – MacPro3,1
      – MacPro4,1
      – iMac8,1
      – iMac9,1
      – iMac10,x
      – iMac11,x (Systeme mit AMD Radeon HD 5xxx und 6xxx Serie Grafikkarten sind fast unnutzbar wenn sie unter Mojave laufen. Mehr Details dazu in der Bekannte Probleme-Sektion unten.)
      – iMac12,x (Systeme mit AMD Radeon HD 5xxx und 6xxx Serie Grafikkarten sind fast unnutzbar wenn sie unter Mojave laufen. Mehr Details dazu in der Bekannte Probleme-Sektion unten.)
      – MacBookPro4,1
      – MacBookPro5,x
      – MacBookPro6,x
      – MacBookPro7,1
      – MacBookPro8,x
  • – Ende-2008 oder neueres MacBook Air oder Aluminum Unibody MacBook:
    – MacBookAir2,1
    – MacBookAir3,x
    – MacBookAir4,x
    – MacBook5,1

    – Frühjar-2009 oder neueres Mac Mini oder weißes MacBook:

    – Macmini3,1
    – Macmini4,1
    – Macmini5,x
    – MacBook5,2
    – MacBook6,1
    – MacBook7,1

    – Frühjar-2008 oder neuerer Xserve:

    – Xserve2,1
    – Xserve3,1

Nicht unterstützte Geräte:

- 2006-2007 Mac Pros, iMacs, MacBook Pros, und Mac Minis (MacPro 1,1 und 2,1, iMac 4,1, 5,1, 5,2, 6,1 and 7,1, MacBook Pro 1,1, 2,1, und 3,1, Macmini 1,1 und 2,1)
-- Der
 2007 iMac 7,1 ist kompatibel wenn die CPU auf einen Penryn-basierten Core 2 Duo, wie den T9300 aufgerüstet wurde.- 2006-2008 MacBooks (MacBook 1,1, 2,1 3,1 und 4,1)
- 2008 MacBook Air (MacBookAir 1,1)


Vorbereitung:

Bitte stelle sicher, dass SIP auf dem Gerät, auf welchem Mojave installiert werden soll, deaktiviert ist. Solltest du dir nicht sicher sein, boote einfach in deine Recovery-Partition deiner aktuell von dir installierten OS X-Kopie, öffne das Terminal und führe den Befehl “csrutil disable” aus. Bitte sei dir im Klaren darüber, dass SIP solange deaktiviert sein muss, wie du Mojave benutzen möchtest. Mehr zu SIP >>

Solltest du oder dein System SIP wieder aktivieren, wird dich Mojave darüber informieren und warnen. Achte außerdem darauf, wenn möglich keinen PRAM-Reset durchzuführen, da sonst SIP wieder aktiviert wird.


Des weiteren benötigst du:

  • Die Catalina Installations App – Sie kann über den App Store einer Maschine mit Mojave-Unterstützung heruntergeladen werden
  • Einen USB-Stick mit mindestens 16GB Speicherplatz
  • Das Patching-Tool – Hier bekommst du Version 1.2.2 (altere Versionen auf der Seite des Programmierers)

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro


Bekannte Probleme:

Momentan werden einige pre-metal Grafikkarten nicht richtig unterstützt. Dies zeigt sich durch eine merkwürdige graue Menüleiste und Finderfenster im “Hellen Modus”. Im Dunkles Modus erscheinen diese Fehler nicht.

AMD Radeon HD 5xxx/6xxx series GPU acceleration: Currently, it is not possible to get full graphics acceleration when running Mojave on a system with a Radeon HD 5xxx or 6xxx series GPU. Mojave will be almost UNUSABLE without graphics acceleration. This includes the 15″ and 17″ MacBook Pro systems (MacBookPro8,2 and 8,3). If you want to enable GPU acceleration on these machines, you’ll need to disable the AMD GPU (This will work on MacBook Pro 8,2 and 8,3 systems ONLY. You CANNOT disable the AMD GPU in an iMac.) Weird colors will also be produced when running Mojave with one of these video cards installed/enabled. To disable the AMD GPU on a 2011 MacBook Pro 8,2 or 8,3, follow the guide found here.

Early-2008 Mac Pro (MacPro3,1) GPU support: When running Mojave, you CANNOT use a newer AMD video card EVEN IF it is a Metal-comptible card and is supported in Mojave. The newer AMD drivers used in Mojave require the SSE4.2 instruction set, which the MacPro3,1 does not support. There is no way around this at this time. Your only GPU upgrade options for MacPro3,1 systems are nVidia cards, which work perfectly fine.

Built-in iSight cameras: Currently, built-in iSight cameras do not work correctly on some machines. It seems to be hit or miss, but when installing, expect your iSight camera to be non-functional.

Trackpad (MacBook5,2 affected only). The trackpad in the MacBook5,2 isn’t fully supported in Mojave. While it works and is fully usable, Mojave detects it as just a standard mouse, preventing you from changing some trackpad-oriented settings.

Einige W-Lan Module werden von Mojave nicht mehr unterstützt. Hier ist ist eine Liste aller bekannten Module, welche unter Mojave nicht funktionieren werden. Prüfen kannst du das im Systembericht per Klick auf “Über diesen Mac” im Apple-Menü und einen weiteren Klick auf “Systembericht”.

Macs mit dem W-Lan Modul Broadcom BCM4321 haben kein funktionierendes W-Lan unter Mojave. Bei einem Klick auf “WLAN” im Systembericht kannst du prüfen, ob dein Mac über eines der nicht funktionierenden Module verfügt.

(0x14E4, 0x8C), (0x14E4, 0x9D),  (0x14E4, 0x87), (0x14E4, 0x88), (0x14E4, 0x8B), or (0x14E4, 0x90)

Alle anderen Kombinationen wie (0x14E4, 0x8D) werden unterstützt.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Außerdem funktioniert das Trackpad beim MacBook5,2 nicht richtig. Mojave erkennt dieses als Maus und somit fehlen einige Einstellungen.


Die Installation von MacOS Mojave

Schritt 1:

Schließe deinen USB-Stick an deinen Mac an, öffne das Festplattendienstprogramm und formatieren den Stick zu “Mac OS Extended (Journaled)”

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 2:

Nutze weiterhin das Festplattendienstprogramm, um deiner Festplatte eine weitere Partition für deine Mojave-Installation zu geben, sofern du Mojave nicht auf einem anderen Medium installieren willst. Dazu einfach deine Festplatte auswählen, eine aktuelle Partition auswählen, das “+” drücken und die Größe wählen. Es ist nicht empfehlenswert, dein aktuelles System durch Mojave zu ersetzen, da eine spätere Update-Unterstützung nicht garantiert werden kann.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Damit hast du später bei der Installation direkt eine Partition, auf der du Mojave installieren kannst. Andernfalls kannst du dies auch später bei der Installation erledigen.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 3:

Öffne den “macOS Sierra Patcher” und wähle damit deine zuvor heruntergeladene macOS Mojave Installations-App aus. Für gewöhnlich heißt sie “macOS Mojave installieren”. Nimm nicht die .dmg-Datei sonder das daraus resultierende Programm.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Stelle bitte sicher, dass das Tool Mojave danach erfolgreich verifiziert.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 4:

Wähle deinen zuvor formatierten USB-Stick aus und klicke auf “Start Operation”.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 5:

Wenn der Vorgang abgeschlossen ist, boote zu deinem USB-Stick, indem du direkt nach einem Start oder Neustart die Alt- bzw. Optionstaste gedrückt hältst.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 6:

Installiere macOS Mojave auf der gewünschten Partition.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 7:

Wenn die Installation fertiggestellt wurde, boote sofort wieder mit der gedrückten alt-Taste zu deinem USB-Stick. Dieses mal wollen wir den “macOS Post Install” ausführen.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

In dem Programm wählst du dein aktuelles Mac-Modell. Im besten Fall erkennt das Programm dein Modell und zeigt dir den Modellnamen sofort an. Nun können weitere Patch-Optionen gewählt werden. Normalerweise macht das Programm aber ganz automatisch das, was für deinen Mac richtig ist. Danach einfach nur noch die Partition wählen, auf der Mojave installiert wurde und auf “Patch” klicken.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Danach das Gerät einfach per Klick auf “Reboot” neustarten. Dabei ist wichtig, dass du wieder mit der alt-Taste in das Boot-Menü kommst und dann die Partition mit Mojave auswählst, sofern dein Mac das nicht von selbst macht. Sollte etwas nicht funktionieren, boote erneut auf den Installations-Stick und wähle im Post-Install Programm einfach zusätzlich “Force Cache Rebuild” an. Normalerweise ist das aber nicht vonnöten.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Schritt 8:

Nach dem Neustart solltest du in einer komplett funktionierenden Kopie von macOS Mojave landen.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Fertig! 🙂


Weiteres zu MacOS Mojave:

Wenn im Post-Install-Tool ausgewählt, hat man später ein Programm namens “Patch Updater” installiert. (Programme/ Dienstprogramme) Dieses Programm wird sich bemerkbar machen, wenn neue Updates zu Patches verfügbar sind und wird diese auf Wunsch installieren.

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro

Wenn es bei Night Shift Probleme gibt: Um Night Shift auf deinem Gerät zu aktivieren, installiere einfach dieses Tool. Die Credits gehen hierbei an Piker Alpha und Foxlet.

Alles weitere steht zum Beispiel in einem FAQ auf der Originalseite. Bei weiteren Fragen stehe ich aber durch die Kommentare gerne zur Verfügung. Und ansonsten: Einen neuen Mac kaufen. 🙂

macOS Mojave auf nicht unterstützten Geräten installieren - Eine deutsche Anleitung - macOS Patcher Anleitung Apple iMac iMac Pro Mac Mac Mini Mac Pro MacBook MacBook Air MacBook Pro
Foto: unsplash/HOWARD BOUCHEVEREAU


Jetzt TheQuickSaveGamer unterstützen!


Diskutiere zu diesem Thema auch im Forum

3+

27 Kommentare für “macOS Mojave auf nicht unterstützten Geräten installieren – Eine deutsche AnleitungKommentar hinzufügen →

  1. Hallo Maximillian,
    vielen Dank für die hervorragende Anleitung. Bei mit (MacBook Pro 7.1) hat die Installation nach zwei Anläufen funktioniert. Das System startet gut, der Patch Updater zeigt allerdings folgende Fehlermeldung:
    This patch, utilizing “SUVMMFaker.dylib” created by Czo, allows users of macOS 10.14 on unsupported machines to update their systems to new releases of macOS Mojave.

    – This update will remove the “MacBook Pro T2 Supplemental Update” from your list of available software updates, preventing it from being installed.

    Darüber hinaus lässt sich der Punkt “Softwareupdate” in den Systemeinstellungen nicht mehr. Anwahl tut sich hier nichts, die Systemeinstellungen können nur noch über “sofort beenden” geschlossen werden.

    Kann du mir einen Tipp geben, wie ich die Fehler beseitigen kann? Vielen Dank im Voraus.

    Mit freundlichen Grüßen
    Martin

    Nachtrag: sorry, ich vergaß: Das o.a. Update/bzw. die Installation wird nicht durchgeführt.
    Viele Grüße
    Martin

    2+
    1. Hallo Martin,

      das freut mich sehr zu hören! 🙂

      Welche Version vom Patcher hast du denn genommen? Probier die Installation sonst am besten mal mit der neusten Version 1.3.7 von dosdude.
      Achte auch darauf dir ein aktuelles Update von Mojave runterzuladen. Du kannst theoretisch eine neuere Version von Mojave über die alte installieren und nach einem Post-install sollten alle Daten noch vorhanden sein. Quasi ein Update. 😉

      Aber bevor du gleich alles neu installierst noch ein Hinweis: Die Systemupdates laufen wohl nur wenn deine SSD im APFS-Format formatiert wurde. Falls deine noch mit macOS Extended formatiert war, versuch einfach sie im Festplattendienstprogramm zu konvertieren. Probier also erstmal das aus.

      0
      1. Hallo Maximilian,

        vielen Dank für die schnelle Antwort. Ich werde es gleich aufs neue versuchen. Die Festplatte ist im APFS-Format formatiert, Mojave hat die Version 10.14.6, so dass dies keine Baustellen sind (hoffe ich).

        Viele Grüße
        Martin

        2+
    2. Hallo Martin, Ich habe leider exakt das gleiche Problem wie Du es im allerersten Kommentar beschreibt (Update auf Mojave erfolgreich, aber Patch-Updater nicht updatebar, und Softwareupdate (unter Systemeinstellungen) nicht ausführbar, sondern freeze von der Systemeinstellungs-App.
      Leider hast dann nicht mehr gepostet, ob – und falls ja wie – Du das Problem lösen konntest.
      Hast Du es hinbekommen? Wenn ja, wie? Danke!!!

      1+
      1. Moin Matthias,

        ich würde dir gerne mitteilen, dass ich eine geniale Lösung gefunden habe. Leider war dies nicht der Fall. Ich habe einfach weiter installiert, bis es irgendwann geklappt hat. Also Geduld. Es lohnt sich, das System läuft nun seit einem Jahr stabil.

        Mit freundlichen Grüßen
        Martin

        0
        1. Hui, danke, Martin! Ich war mir echt nicht sicher, ob Du nach so langer Zeit noch antworten würdest…
          OK, dann gebe ich einfach nicht auf sondern probiere solange weiter, bis es klappt!
          BTW: Bist Du immer noch auf sen gepatchten Mojave? (ich wollte eigentlich auf ein gepatchtes Catalina updaten, habe dann aber gesehen, dass da bei jedem Update komplett neu installiert werden müsste., während beim Mojave-Patch in diesem Fällen nur die Post-Patch-Sachen neu gemacht werden müssen. Das stimmt doch so, oder?)
          VGs Matthias

          1+
          1. Hallo Matthias,

            ich nutze gleichzeitig neben dem besagten Macbook noch einen anderen Rechner, der mit Mojave arbeitet. Da ich bei einer Umstellung beide Systeme neu aufsetzen müsste, habe ich mich noch nicht an die Arbeit gemacht. Deshalb kann ich dir über das Updaten wenig mitteilen.
            Viele Grüße und viel Erfolg!
            Martin

            1+
          2. Danke, Martin, für die Info! Ja, ein Jahr hast Du ja noch, in dem Du auch mit Mojave mit Updates versorgt wirst! 🙂

            Hallo Max, meintest Du den Mojave-Patcher oder den Catalina-Patcher mit Deiner Aussage, dass Updates inzwischen möglich sein müssten?

            Viele Grüße und einen schönen Abend, Matthias

            PS: Mein Wissensstand ist, dass beim aktuellen Mojave-Patcher Updates möglich sind, beim aktuellen Catalina-Patcher aber nicht (Workaround ist, jedesmal komplett neu einen Patcher-USB-Stick zu erzeugen und das OS „neu“ über das gleiche OS – nur eben eine Version aktueller – drüberzuinstallieren. Echt viel Aufwand und Zeit also…). Und diesen Wissenstand wollte ich challengen, nicht dass ich da im schlimmsten Fall einer Fehlinformation aufsitze!

            0
          3. Hey Matthias,

            ich meinte tatsächlich den Catalina-Patcher. 😉 Aber selbst ausprobieren konnte ich das bisher leider auch noch nicht. Es kann aber sein, dass du dann trotzdem zumindest den Post-Install nochmal ausführen musst. Aber falls du das mal heraus bekommen solltest, lass es auch mich gern wissen! 🙂

            Viele Grüße,

            Max

            1+
          4. Hi Max, ich habe inzwischen auf meinem late 2009-Macbook (das weiße 6,1) neben High Sierra auch ein lauffähig gepatchted Catalina und ein lauffähig gepatchted Mojave drauf (Danke, Stefan, für den Tipp mit dem Durchhalten, schon beim 2. Versuch hat er dann geklappt!)

            Beim gepatchten Catalina kommt man zwar ganz normal unter Systemeinstellungen in das Software-Update-Fenster rein, es zeigt aber an, dass es keine Updates gäbe (obwohl bei mir lt. der Build-Nummer das ergänzende Update für 10.15.7 vom 5. November noch fehlt). Und in anderen Foren wird das auch diskutiert, dass das Software-Update-Fenster beim gepatchten Catalina ohne Funktion sei, und man zum Updaten immer auf einen neuen Installer von Apple warten müsste, aus diesem und dem Patcher dann einen aktuellen Patch-Stick bauen müsste, und mit dem dann Catalina neu über das vorhandene Catalina drüberinstallieren müsste (zumindest die Post-Patch-Sachen macht der Catalina-Patcher ja automatisch, ist aber trotzdem jedesmal ein Heidenaufwand – und außerdem fraglich, ob Apple für Catalina zukünftig, wo es ja nicht mehr das aktuelle OS ist, überhaupt noch neue Installer rausbringt, oder evtl. nur inkrementielle Sicherheitsupdates, die dann gar nicht auf gepatchten Catalinas installierbar wären – so wie im Moment das oben genannte Ergänzende Update für 10.15.7)

            Beim Mojave-Patcher hingegen ist Updaten ja recht einfach: Dort funktioniert das Software-Update-Fenster tatsächlich wie gewohnt, lediglich nach dem dann folgenden Neustart muss man dann einmalig zuerst kurz vom USB-Stick starten und die Post-Install Patches nochmal durchlaufen lassen. und den Cash rebuilden. Dauert 1 min.. Ab dann kann man das upgedatete System wieder ganz normal starten.
            Geht also viel einfacher und schneller als beim Catalina-Patcher; vor allem aber klappt das eben auch bei inkrementiellen Updates, von denen Apple keinen kompletten Installer zur Verfügung stellt.

            Das sind alles meine Erfahrungswerte und heute abend von mir so getestet. Wo hast Du denn gelesen, dass das Updaten mit dem Cataline-Patcher inzwischen sinnhaft funktionieren soll? Das wäre ja super interessant und wichtig ab kommendem Herbst, wenn Mojave dann keine Sicherheitsupdates mehr bekommen wird.

            Viele Grüße!! Matthias

            1+
  2. Hallo Maximilian,

    nun ist die Installation mittels des von dir geposteten Links erneut ohne Probleme durchgelaufen, Mojave zeigt aber nach wie vor dieselben Probleme.

    Leider findet sich die gesuchte Datei SUVMMFaker.dylib nicht auf dem USB-Stick.

    Hast du vielleicht noch einen Tipp?

    Viele Grüße
    Martin

    3+
    1. Hey Martin,

      also hat sozusagen auch das manuelle “Update” nicht geklappt? Vielleicht klappt ja das:
      Lade dir mal diesen Patch herunter: http://dosdude1.com/sierra/swupatch.sh.zip, öffne dann dein Terminal und ziehe den Patch da rein. Jetzt müsste die SUVMMFaker.dylib unter /usr/local/lib/ liegen. Dann müssten dir wieder Updates angezeigt werden. Der User MacPeet schreibt aber auf root86 noch, dass folgendes wichtig ist VOR dem Update:

      “Ab hier wird´s knifflig, Apple hat aus den Erfahrungen mit Sierra und den unsupported Mac´s wohl auch dazugelernt, aber nicht genug für uns, hihi.
      Unter Sierra liefen die Updates noch in einem Schritt, d.h. Update starten, Neustart und Installation und fertig. Auf High Sierra ist es nicht mehr so einfach, die Updates laufen mehrstufig ab und jeder Schritt unterliegt der supported Mac Kontrolle.

      Hier braucht Ihr die Atom Beta.app auf Eurem High Sierra, oder Ihr verwendet die vorgefertigte Datei 091-19061.German.dist von mir (hier ist aber nur der MacPro3,1 nachgetragen).
      Wir öffnen nun den Finder in folgendem Ordner: /Volumes/HighSierra/Library/Updates/ und starten nun im AppStore/Updates/ das Beta2-Update und folgen dem Hinweis auf den nötigen Neustart. Sobald der Download läuft taucht in dem Ordner Updates, ggf. Unterordner mit UpdateNummer die Datei 091-19061.German.dist auf. Diese kann im Namen je nach verwendeter Sprache und späterer Updates variieren. Wenn der Name passt und Ihr auch eine MacPro3,1 habt, könnt Ihr meine Datei übernehmen, ansonsten müsst Ihr diese in der Atom Beta.app öffnen und bearbeiten, in der supported-Sektion die BoardID Eures Mac´s eintragen und in der unsupported-Sektion den Modellnamen Eures Mac´s rausnehmen.
      Auf jeden Fall ersetzt Ihr die bearbeitete .dist-Datei in diesem UpdateVerzeichnis. Hier habt für diesen Schritt genug Zeit, da der Download min. 20 Minuten dauert. Die .dist-Datei ist die erste Datei, gefolgt von einer .plist, gefolgt von 4 .pkg-Dateien.
      Ich hoffe, Ihr habt alles richtig verstanden und auch richtig gemacht bis dahin. Der Download endet nun und es erfolgt der Neustart und der anschließende Ladebalken für´s Update, dann der Neustart.
      An dieser Stelle booten wir wieder ins Sierra (nicht ins MacOS Installer im BootMenü), denn wir müssen auch hier nochmal eingreifen, denn auch hier gibt´s wieder eine Supported-Kontrolle.
      Im Sierra geht Ihr im Finder zu Eurer HighSierra-Platte/SSD, auf der im root-Verzeichnis nun ein extra Installverzeichnis ist mit ggf. Unterordnern. Auf jeden Fall gibt es hier eine PlatformSupport.plist. In dieser müsst Ihr Eure BoardID nachtragen und Mac-Namen. Für den MacPro3,1 hab ich diese schon vorbereitet, siehe Archiv.

      Dann Neustart, die Zweistufige Installation zu Ende laufen lassen. Dann erfolgt der Neustart und ab geht´s ins fertige System Beta 2 High Sierra, es sei denn Ihr habt die HD5770, dann startet Ihr vorher nochmal ins Sierra und macht wieder das Rollback der Grafikkexte wie oben beschrieben. Danach Neustart ins High Sierra und Ihr seid auf Beta 2. Glückwunsch.”

      Viele Grüße

      Max

      0
      1. Hallo Max,

        vielen Dank für deine Hilfe, die Batchdatei funktionierte leider nicht. Daher habe ich auch die anderen Schritte nicht durchgeführt, se bezogen sich auf High Sierra, während ich Mohave nutze.

        Herzliche Grüße
        Martin

        2+
          1. Hallo Max,
            vielen Dank für deine Hilfe. Super, dass du dir die Mühe gemacht hast. Ich werde mal eine Mail an die angegebene Adresse schicken. Mal schauen, wie es weitergeht.

            Herzliche Grüße
            Martin

            2+
  3. Hallo ich habe auf meinem alten imac 2008 10.14.6 instaliert mit dem toll soweit alles super nur habe ich dann bei updates von apple gesucht und ein sicherheitsupdate instaliert . Danach geht garnichts mehr musste alles neu machen. 10.6.3 – 10.6.8 – 10.11.6 – 10.14.6
    darf man das instalieren aber wie oder soll man das einfach lassen mfg Hendrik

    2+
      1. Ja ssd hatte ich eingebaut .und Mojave in dem Format installiert dann zeigte er mir Sicherheitsupdate an . Da nach 10.14.6 denke kein x.x.7 kommen wird dachte ich mir Sicherheitsupdates gehen ohne Probleme . Aber falsch gedacht danach ging nix mehr , nichtmal von usb Stick starten und denn patcher nochmal aufführen . Also habe ich alles neu gemacht und in normalen Format installiert da ich sowieso keine Updates oder Sicherheitsupdates über Updates installieren soll.

        2+
        1. Hmm, also der USB-Stick müsste eigentlich trotzdem noch gehen. Klingt nach etwas schwerwiegenderem. Das mit dem Updates beim Patcher ist leider immer noch nicht so optimal. Mein Mac Mini lädt die Updates zwar, aber im Endeffekt wurde nichts installiert. Am MacBook geht’s jedoch.

          0
    1. Hallo Yanneck,

      ich habe dasselbe MacBook bei mir zuhause und hier funktioniert das Trackpad. Wenn es bei dir vorher funktioniert hat, solltest du mal checken ob du den Post-Install nach der Installation von MacOS Mojave richtig ausgeführt hast. Der Entwickler beschreibt keine Probleme bei diesem Modell. Beim MacBook 5,2 soll es Probleme geben, aber nur weil Mojave hier das Trackpad nur als Maus erkennt.

      Beste Grüße

      Max

      0
  4. Ich habe leider exakt das gleiche Problem wie Martin Seiler im allerersten Kommentar beschreibt (Update auf Mojave erfolgreich, aber Patch-Updater nicht updatebar, und Softwareupdate (unter Systemeinstellungen) nicht ausführbar, sondern freeze von der Systemeinstellungs-App.
    Leider hat Martin dann nicht mehr gepostet, ob – und falls ja wie – er das Problem lösen konnte.
    Hat jemand noch eine Idee? Danke!!!

    1+
    1. nur für die Akten: Habe den Mojave-Patch dann (wie von Martin empfohlen) ganz von Anfang noch mal gemacht -diesmal als clean install, keine Ahnung ob das den Unterschied machte – und seither läuft das gepatchte Mojave auf meinem late 2009er Macbook 6,1 perfekt und incl. den Software-Update-Möglichkeiten (also aktuell incl. 2020-006 und Safari 14.0.1). Bin begeistert!
      Witz am Rand: Das Update-Fenster zeigt mir jetzt das Big Sur Upgrade (11.0.1) an !!! Ich würde gern ein „Beweisphoto“ posten, geht das hier in diesem Forum? Iw auch immer, ich werde es nicht ausprobieren, das kann ja nur schiefgehen… Obwohl…??? Hm…

      1+
      1. Hi Matthias,

        wow, danke für deinen Input! Ich glaube das wird vielen Nutzern hier nochmal ein ganzes Stück weiterhelfen. Ich werde wohl die nächsten Tage nochmal ein wenig Text aus deinen Erfahrungen basteln und in den Artikeln ergänzen. Wenn du ein Bild in die Kommentare einfügen möchtest, probier es mal mit {img src=”http://bildurl” alt=”Bildtext” /}, nur statt der { eben < Klammern. Falls das nicht klappt, schick mir das Bild gerne hier als Ticket und ich füge es hier ein.

        Das hier ist ja so direkt noch kein richtiges Forum, aber wenn du meinst, es könnte euch beim Austausch helfen und für einen besseren Überblick sorgen, richte ich gern eins ein. 🙂

        Ich wünsch dir aber jetzt erstmal viel Spaß mit deinem Mac und Mojave! 😉

        Beste Grüße,

        Max

        0
        1. Hi Max,

          danke für Dein Feedback – ich hoffe ja nur, dass meine Erfahrungen allgemeingültig und korrekt sind – evtl. findet sich ja noch jemand, der es ebenfalls selbst ausprobiert hat und es bestätigen oder korrigieren kann!
          Na, hat niemand sonst noch einen alten Mac, der dringend mal gepatched werden sollte…? 😉

          VGs, Matthias

          1+

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.